MultipassBitmap Alpha Structure



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 10/03/2005 at 21:58, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   9.1 
    Platform:   Windows  ;   Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    I'm having difficulty retrieving the alpha component from a multipass bitmap layer in floating point color mode (RGBAf).

    When saved out the original file definitely contains Alpha data for the layer, however I'm unable to retrieve it through MultipassBitmap.

    I've tried retreiving the fourth Real in the hope that this would be the alpha from the layer data, checking for sublayers, checking for subalpha and hidden layers. Finding the internal channel. Unfortunately so far I've had no luck at all.

    The documentation says that the alpha is a floating point value too, so it can't really be retrieved through GetAlphaBitmap (especially as there's no internal channel to get).



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 14/03/2005 at 05:49, xxxxxxxx wrote:

    Where did you find a buffer in MODE_RGBAf? I'm having trouble setting up a test environment for this. Could you post some code?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/03/2005 at 11:27, xxxxxxxx wrote:

    Sorry my mistake. You're right, alpha in a render is stored in a seperate layer only.


Log in to reply