RenderDocument - Render Animation



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/02/2005 at 06:18, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:    
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Well, I'm somehow stuck again.

    I've figured out how to render an image but I can't render a whola animation (or some frames).

    Even if I try and get the RenderData from the document (and set it to render 5 or 6 frames) it just saves one single image.

    I've tryed with own Render settings, created a BaseContainer called RSettings and used SetData to manually set RDATA_FRAMEFROM ect. but it just doesn't work.

    I'm pretty sure this is just a simple and stupid mistake on my side but I just can't figure it out.

    Here is the code:

    BaseDocument *doc = GetActiveDocument();
    CamImage = BaseBitmap::Alloc();
    CamImage ->Init(width, height, 32);

    RenderDocument(doc, doc->GetActiveRenderData()->GetData(), NULL, NULL, CamImage, 0, NULL);

    ShowBitmap(CamImage);

    ------

    Thanks



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 23/02/2005 at 01:42, xxxxxxxx wrote:

    Hm, just in case anyone cares..

    I've found a workaround (or maybe that's the way C4D handles rendering multiple frames? - I don't think so)

    I used the "BaseTime" parameters to get the frames I want and render them "by hand".


Log in to reply