Probleme beim Kopieren



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 04/02/2005 at 06:20, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   8.500 
    Platform:   Windows  ;   
    Language(s) :   C.O.F.F.E.E  ;

    ---------Hi zusammen,
    ich habe folgende Probleme beim Kopieren von einer Datei in ein andere:
    1.In der Datei die ich zu meiner hinzuladen will, ist ein Stage Objekt. Alle Parameter die in den Keys stehen sind dann nach dem Hinzuladen weg.

    2. Es werde zwar die Objekt kopiert(auch die Materialien) und die Materialen sind dann nicht auf den Objekten. Auf den Objekten sind dann nur leere Materialen.

    Kann mir jemand helfen ?

    Viele Grüße Tim



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 05/02/2005 at 01:50, xxxxxxxx wrote:

    Hallo Tim,

    für diese Frage bist Du hier im falschen Forum. Hier geht es um die Programmierung von Plugins und gepostet wird ausschließlich in Englisch.

    Darf ich Dir das C4D-Forum des C4DTreffs an's Herz legen? Es ist das führende deutschsprachige Forum für Deine Frage.

    Ciao

    Kabe



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 05/02/2005 at 02:46, xxxxxxxx wrote:

    Hi Kabe,

    :-) I know that this is is the forum for programming. My question was about plugin programming. Gepostet wird hier auch manchmal in Deutsch. I know C4D treff and I was already active there last jear.

    Here is my problem again in english :
    First: sorry for my bad english.
    1.I want to merge 2 files, so I clone the objects and Materials form one file to an other. It works, but the materials were not correctly placed on the objects. And the keys were copyed, but the information in the keys are lost.
    Can anyone help me ?

    Here is the code:

    ...................
    if (vMat)
     { while (vMat)
      { vDoc1->InsertMaterial(vMat->GetClone(),NULL);
        vMat=vMat->GetNext();
     }}
     vObj=vDoc2->GetFirstObject();
     if (vObj)
     { while (vObj)
      { vDoc1->InsertObject(vObj->GetClone(0),NULL,NULL);
        vObj=vObj->GetNext();
     }}
     vDoc2->Remove();
     KillDocument(vDoc2);
     vDoc2=NULL;
     vDoc1->SetAllBits(vBits);
    .........................................

    Greetings Tim



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 09/02/2005 at 13:56, xxxxxxxx wrote:

    Can nobody help me? Or is my question bad?

    Greeting tim



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 28/02/2005 at 13:26, xxxxxxxx wrote:

    You need to use an AliasTrans for the copying.


Log in to reply