C4D 7.3 plugin crashs under 8.2



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 23/01/2005 at 11:01, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   8.100 
    Platform:      
    Language(s) :   C.O.F.F.E.E  ;

    ---------
    Hi there,

    I'am trying to create a C4D 7.3 version of my plugin. I´ve done all necessary changes to my code to compile the plugin under C++ SDK 7.3 (The code was originally written for SDK 8.5 and had to be changed for SDK 7.3). The 8.2 and 8.5 versions of the plugin doesn´t report any memory leaks or errors.

    The porting to 7.3 works correctly with C4D 8.2 and 8.5 except the fact that - after all work is done - C4D crashs :-(.

    C4D Tracing prints until it crashs (8.2) :
    ---
    C4D Trace Start...
    Memory Start Corrupt
    Memory Corrupt!
    ALERT: F:\work8.x_BP2\src\Richard\Genesis\ge_memory.cpp, Line 905
    ---
    C4D prints:
    ---
    CINEMA_4D.exe - Fehler in Anwendung
    "Unknown software exception" (0x80000003) at 0x778813b1
    ---

    Could it be that this is a bug of the 7.x plugin-emulation of c4d 8.2 and 8.5? If this is only an emulation-error it isn´t really tragically to me, because for me it´s only important that the plugin works under 7.3. Unfortantly I can´t test the plugin under 7.3 because I do only have a licence of 8.x at school.

    I would be glad if anyone can help me with my problem :). Thanks in advance!

    CU .. Philipp



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 24/01/2005 at 05:48, xxxxxxxx wrote:

    Need more information? please let me know!

    Could somebody from the support tell me whats the meaning of:
    Memory Start Corrupt
    Memory Corrupt!
    ?

    Where could be the error?


Log in to reply