3 Question, Keyframe, containers and TAG



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/11/2004 at 23:22, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   9.012 
    Platform:   Windows  ;   
    Language(s) :   C.O.F.F.E.E  ;

    ---------
    Hi all,

    Is it possibile to read keyframe in coffee?

    Containers: Where i can find a guide for containers? I coffee SDK there are a lots container but what data there are inside?

    Espression Plugin TAG: Can i do a Espr. Plug. Tag with parameters in Attribute Manager?

    thanks all
    Renato T.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/11/2004 at 04:00, xxxxxxxx wrote:

    Hi,

    1. No, afaik not yet. COFFEE needs to be updated. You cannot set keyframes since v8 anymore either.

    2. Each object has a container with its own values. For example a light-object has its own ids, which are different from the id´s of a Cube-object. You can find them in the COFFEE SDK under the classes: BaseList2D->BaseList4D->BaseObject (or under Primitives)

    3. No plugintags with Attributes Manager support is not yet available via COFFEE either. COFFEE also here needs to be updated.

    If you have the knowledge (or the ambition) and skills you should consider using the C++ SDK. It has virtually access to all areas and is always up-to-date.

    Hope that helps
    Samir



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/11/2004 at 08:26, xxxxxxxx wrote:

    hi Samir,

    1. Keyframes: so i can Set and Get keyframe for V8 and above? please let me how.

    2. ok :)

    3. C++ SDK: I was hope for better possibility of COFFEE but is a good training for understand how C4D work.

    thanks
    Renato T.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/11/2004 at 08:43, xxxxxxxx wrote:

    1. no, the other way round :) you can only set and get for V7 and lower!


  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/11/2004 at 08:50, xxxxxxxx wrote:

    C++ SDK Caveats:

    1. Obviously, you'll need to be pretty well versed in C++ programming. When I started with the SDK, my main languages were C and Java. I had learned the basics of C++, but had jumped to Java in order to avoid 'cranial implosion syndrome". C++ is a very complex language compared to most others because of its dual existence as both procedural and object-oriented.

    2. In order to create plugins, you'll need MS Visual C++ 6+ for Windows and CodeWarrior 8+ w/MacOS 9 target for MacOS. They're quite a financial investment. Luckily for me, MSDN subscription gave me existing access to the first.

    3. Following 2., you'll need to either develop the source for the plugin with both platforms in mind, or port one to the other making the appropriate changes (Endian, file specifications, etc.).

    4. You'll need to decide the base version for which to provide the plugin. Using the latest SDK will more than likely forbid use of it in earlier versions of C4D. Part of this decision will depend upon the C4D features used by the plugin (e.g.: one cannot reasonably expect to see Soft IK supported using v6 or 7.3). Of course, you can 'unlock' features depending upo the user's version.

    So, in order to gain all of the access afforded by the C++ SDK, one must lose the simpler programming language, untyped variables, automatic portability. In my current case, it was a required tradeoff.

    If you are willing to learn the SDK (and we're here to help) and determined to do things not possible in COFFEE, C++ is the way to go.

    Robert


Log in to reply