Error making plugin



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 10/01/2004 at 19:47, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   6.3 
    Platform:      Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    I have downloaded the SDK for version 6.3 and tryed to make the plugins included. When I compile them I get 2 errors; "exception specification list mismatch c4d_memory.h line 22 void operator delete(void *p);" as well as "exception specification list mismatch c4d_memory.h line 23 void operator delete[](void *p);"

    Any ideas whats wrong? I am using the CodeWarrior 9.0.

    Cheers



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/01/2004 at 06:08, xxxxxxxx wrote:

    It's probably complaining about the debug versions of the delete operator. You have to copy the new operator signature and make a new delete function. (I think there's a thread about this with newer SDKs. Please search the forum.)


Log in to reply