Solved something problem with using TreeViewCustomGui

hello guys:
when i'm using TreeViewCustomGui(python),there is some problem。
1.CUSTOMGUI_TREEVIEW is empty,this is some ??? showing in the form😵
2.when i use DLG_TYPE_ASYNC, the open form show empty, if i instead of using DLG_TYPE_MODAL it shows normal。
does somewhere i use wrong?

sorry about the grammar
best wishes

Hello @mogli,

welcome to the Plugin Café community and thank you for reaching out to us. You did (almost) everything correctly with your first question, but I would nevertheless recommend having a look at out Forum Guidelines which line out the scope of support and how things do work here. One thing though, it is often best to provide executable example code for a problem.

About your Problem

The ??? text is intended an indicates an empty treeview, i.e., when its root contains no items. You are supposed to display here text as for example 'Drag documents into this field'. You can set the text with the method TreeViewFunctions.EmptyText().

When you continue to run into problems, I would have to ask you to share:

  • Executable code which has been minimized.
  • The version of Cinema 4D you are using.


MAXON SDK Specialist

@ferdinand thank you very much,it had been solved According to your method,have a good day!