Solved I have a problem converting a Osweep object to editable.

The object will be converted, but will be turned into a sinusoid polygon editable.

Used command:



I exported the scene pre and post operation and it is actually this command producing the result.

The sweep Object is a pretty standard cable with diameter and a spline to trace.

Thx to all of you for reading and helping. Pretty great comunity.

Hello @fss,

Thank you for reaching out to us. I am struggling a bit with what you mean by "a sinusoid polygon editable". Do you mean that your object is being unintentionally deformed when being made editable, as for example into a wavy, sine-like form? This would indeed be very odd, and we cannot tell you here more without the exact example code and the scene/object you are running it on. Screenshots would also be welcome in this case. For such odd cases we will also need the operating system you are running the code on, as we will try to replicate your problems.

This all seems very unlikely though, and I would expect some form of user-error to be the cause. But with the provided information, it is impossible to say what you are either doing or understanding wrong.

PS: Although CallCommand is technically fine, it comes with disadvantages. Which is why we always do recommend using the more complex command functions, c4d.utils.SendModelingCommand in this case. I just recently provided a small selection of modelling related Python examples, including SMC. Find them here. The relevant command would be c4d.MCOMMAND_MAKEEDITABLE in your case.


MAXON SDK Specialist

@ferdinand Thanks for your reply Ferdinand.


One converted out example looks like this, having no resemblance to the original object which was a cable in a spiral. Some other examples exist, were the spiral is sqashed into a eardrum like shape.

It seems the spiral modifier data structure (which should be a sinus applied over a 3dimensional circle ) is squashed into a 2dimensional concept. You can even see a second sinus multiplied in at the end.

I shall try to use the Modelcommand recommend by you. Sorry for the slow replying.

Hello @FSS,

this is indeed very odd. If possible, we would like to have that scene and the script you ran on it. It smells very much like a bug, although I would not fully rule out a user error yet. When you are not at liberty to share the scene and code publicly, then you can send them to us via sdk_support(at)maxon(dot)net. When you are a beta tester, you should use our bug-tracker instead and prefix the issue title with [Python].


MAXON SDK Specialist

Im sorry, i can not send you the customer files. As soon as the team has any time, we will reproduce the test case in a seperate 3d file and send it with the code-sample.

Hey @FSS,

No problem, we understand. I would however recommend keeping in mind that there is still the possibility that a user error is the cause of all this. Which could mean that you will run into the same problem/outcome when using SendModelingCommand, depending on what you are doing exactly.

The problem for me is still that I am not sure what you are doing exactly. E.g., what is the 'spiral modifier (data structure)' for you? But when I do what seems likely to be what you are doing, add a 'Twist Object' to some parametric spline input, 'Make Editable' works fine for me, both invoked from the app as well as a Python CallCommand script.

It might be helpful to point out that there is a difference between 'Make Editable' and 'Current State to Object'. While the former will effectively replace a generator with its collapsed cache (not deform cache), the latter will collapse whole hierarchies and also include deform caches in this collapsing. Depending on what you are doing, this will make a huge difference, especially when you start copying things, as nodes collapsed with 'Make Editable' still have dependencies. I.e., when you copy the output of 'Make Editable' without its children, tags, etc. just somewhere else, it could very well be that this copied object then is missing other things which influence it in some way, resulting for example in your odd outputs.


Me poking around with a simple example:


MAXON SDK Specialist

Hello @FSS,

without further questions or postings, we will consider this topic as solved by Wednesday 31/05/2023 and flag it accordingly.

Thank you for your understanding,