Calling a blocking Plugin

So i have a plugin we bought, thats doing what its supossed to do, but once i call the menue with my python script, i lack the ability to apply it. I tried threading, but cinema4d is (wisely) on the side of us devs threading lightly.

def main():
    doc = documents.GetActiveDocument()    
    ackThread = threading.Thread(target=acknowledgeThread)
    tool = c4d.plugins.FindPlugin(CORONA_TO_CV4DMATERIAL_CONVERT) # Search Transfer Tool instance
    c4d.CallButton(tool, c4d.MDATA_APPLY)

PS: Usually there is a header file with menue options listed that can be called as commands. My first attempt was to itterate from the plugins command nr upwards in a for loop until i found another plugin. No changes were applied.

Finally, i tried to de-obfuscate the python bytecode, to repair the plugin, but failed due to lazyness. (Its identifying header + barrelshift & XOR?)

Has anyone solved this in python && Commandline.exe? I dont wanna go to AutoIt and full gui..

Hi FSS, thanks for reaching out to us.

Your question it's outside the support purview of the SDK Team and, hence, we can't help. I also recommend refraining on talking, in this forum, about software reverse engineering or software hacking: this is not allowed under any circumstance.
Finally, if you need to script the plugin execution, consider reaching out to the software vendor which might provide, given his knowledge on the plugin design, more valuable insights.

Best, Riccardo