Solved Can GeGetStartupWritePath return icorrect path?

Hello guys!
I have an issue from customer. He uses Cinema 4D R19 on MacOs High Sierra and gets this error when my python plugin trying to create folder with os.mkdir in Maxon folder that is parent of Cinema 4D Prefs folder (GeGetStartupWritePath):

Error type: OSError,
[Errno 13] Permission denied: '/Volumes/cc/c3d/plugin_prefs_folder'

Here is result if calling in a customer console:


Why this path so strange? How it can happend? This is a OS issue and it is impossible to create folder on one level upper than C4d Startup Write Path?

Checkout my python tutorials, plugins, scripts, xpresso presets and more


I've tested it on my mac the resulting path is the same that you can see at the bottom of the preferences dialog box (cmd+E)
Some strange scenarios could happen on his computer. This path is generated every time cinema4D starts.
If the updater is launched, the updater can passe to cinema4D an argument that will change this path. That could explain why, with a R19, it displays R20 on the path.

  • I would check what path the user has in the preferences dialog box.
  • I would check if the user doesn't launch cinema4D from a shortcut that could lead to some strange configuration.
  • Checking if he doesn't use g_prefsPath argument also. (even in the resource/config.txt file)
  • Probably re-installing cinema4D will fix this issue.


MAXON SDK Specialist

MAXON Registered Developer

Hello @mikeudin,

without any further questions we will consider this topic as solved by Friday, December the 17th.

Thank you for your understanding,

MAXON SDK Specialist