Solved R25 doesn't register the [c4d.ID_BASEOBJECT_COLOR] parameter

As you can see from the attached image, R25 won't highlight the following parameter:


I'm using this to programmatically change the Display Color of a null, but it doesn't highlight in orange in either the Script Editor (when I type it) or the Script Log (when I manually change the color to trace a call), and since it doesn't recognize it, it throws an error. The same script highlights orange and runs fine in R23. Unless I'm missing something, I believe this is a bug?


Hi @reubenlara, I'm not able to reproduce here ID_BASEOBJECT_COLOR is correctly highlighted in R25.010 in Windows and Mac.

Would it be possible to share your full script with us? And also the complete error log.
However looking at the error the issue come later at the and this is the CallCommand(12298) which fail, moreover according to your screen you do have an object called 3D_Cursor so this branch will never be taken (at least not in your case).

Just to be sure would it be possible for you to write in the console c4d.ID_BASEOBJECT_COLOR and press enter. 908 should be written.

Thanks in advance,

@m_adam OK this is really weird. I tried this over and over yesterday for several hours. this morning it is working fine! It must have been a case of restarting my machine or something. All set on my end! Thanks for testing either way, much appreciated!