Solved No notifications of replies

Since the new forum update I don't receive any notification when someone has replied to a topic I have posted.
I haven't touched the default notifications in my profile settings, so would expect to get notifications.

Hi Daniel, thanks for reporting.
We've not reported by others about this issue, nor we've seen this happening on our profiles. However I'll research next week to see what could be the cause.

Can you confirm which notification is missing? Email notification, forum notification or both?

Cheers, R

I didn't have e-mail notification setup with previous forum, so I don't expect this to be active neither.
I was merely talking about the forum notification, aka "the bell icon".

When I click on that bell icon I see a list of notifications, including your reply.
But in the past that bell icon had a red square with a number of notifications in ... same as with the "unread" icon at the left of the header.
For the unread new post, I do see the "notification" info. Not so for the bell icon.


Hello @C4DS ,

due to this reaching its cutoff cycle: I think this has not been dealt with yet and I apologize for it. The past weeks have been busy, and some hiccups of the new forum(s) is only being dealt with bit by bit. We will report back here when we have a conclusion for the problem.

Thank you for your undderstanding,

MAXON SDK Specialist

Hi Daniel, sorry for coming back only now. I think it's a bug that has been introduced with the theme switch we've done but I'm a little bit puzzled because I can't reproduce it consistently.
If you click any of the top-right circle that appears in the notification drop-down, does the bell shows the counter?
Have you tried to clean-up the cookies, or using a browser in private-mode, to reproduce the issue?

Cheers, R

Well, the notification bell showed the counter this time.
No actions needed from my side.
The problem seems to be fixed.

I haven't been much active the past days, so I haven't had the chance to experience replies on any of my topics ... except for a notification on this particular topic. So, that seems to be working.
I wouldn't put more time into it, as most seem not to experience the issue.

Thanks @C4DS for reporting the recent positive experience.

Unless you experience the issue again in the future, we can consider the case closed.

Unfortunately this particular reply of yours didn't make it as a notification.

No counter was visible, still the notification dropdown had 2 entries with black circles.
When I now select the dropdown and change the hollow circles to black again, then the notification counter shows up.

Very weird. I am confused.

Hello @C4DS,

Well, I had two notifications for the thread for your reply. I am on Microsoft Edge on both Windows and MacOS. I had a similar problem with the forum in the internal beta-phase. The only thing that did help for me was flushing the caches for the main URL of the page in the browser settings. There might have been other things for me at play, but it still could be worth a shot for you.

If this does not work for you, I am pretty sure that we will need more details, operating system, browser, and revision numbers, to investigate the problem. So, it would help if you could provide such information.


MAXON SDK Specialist

So, I have cleared all caches of my browser. Now it's waiting for a reply in order to see if the notification pops up.

In the meantime here's some info:
Windows 10 Home, version 10.0.19041.906
Firefox 88.0.1 (64bit)

test reply

Unfortunately no notification counter to be seen this time around.

Hi @C4DS,

so, I downloaded Firefox, which was the same version as yours, 88.0.1, and I am also running Windows 10 64 bit, although the Pro version. And I cannot reproduce the behavior described by you. The website behaves exactly like in Edge and Chrome for me, which means having one notification in my case currently. See screen below:


So, for clarity, what are you talking about exactly?

  1. The little bell icon with a number next to it, as shown in my screen and indicated by yours? That is what I am assuming.
  2. Notifications in the bookmarks of a browser? These are indeed not working in Firefox for me, but in Edge and Chrome. We consider these to be a non-essential feature and will not fix this unless we have nothing to do else.
  3. E-mail notifications? I am sure that this is not what you are talking about.

If it is just number one for you, we need to know how to reproduce this, as we otherwise cannot fix it (or decide not to fix that special case). And currently I cannot reproduce your problem.

  1. Can you think of anything that might be special about the Firefox instance you are running?
  2. Are there any errors in the JS console of the browser for you?
  3. Do you have any form of content or script blockers active for, as they certainly could screw with this?


MAXON SDK Specialist

We are indeed talking about the little bell icon with a number next to it.

The strange thing is (as mentioned earlier as well) is that the unread icon does show up with a number of new unread posts. So, some of the notifications are working. Just not the bell icon.

When I re-enable a notification in the dropdown of the bell icon, I do see the number show up.
I noticed just recently that when I am currently looking at the forum page and someone replies, the number do show up. But without reading the posts, nor doing any actions and I leave the page, then come back to the forum ... the number on the bell icon is gone. Still the dropdown of the bell icon shows the list of notifications with a black circle next to it. Indicating that the replies have not been read yet.

I don't have any content, script, or ad blocker. All was working fine with previous plugincafe.
I have tried with Microsoft Edge (which isn't my default browser), and have exactly the same issues there. The number on the icon bell isn't displayed.
To me this sounds like it isn't browser related.
Do I have some setting in my account which causes this - no idea?
As said, all worked fine with previous plugincafe, and as far as I remember I haven't changed anything in my account settings since the switch.