Solved GeDialog.AddSeparatorH documentation

I had the following line in a plugin, which was working fine for R17 upto R23.

self.AddSeparatorH(inith=5, flags=c4d.BFH_FIT);

Suddenly with latest S24, a user reports following error in the Python console:

TypeError:Required argument 'initw' (pos 1) not found

Looking at the documentation I now notice why I used "inith", and since this is an horizontal separator one would expect to only provide the height.
However, latest documentation indicates "initw" (initial width) should be used ... which does sound weird.


I haven't older Python SDK documentation at hand, but my guess is this "initw" was erroneously introduced in S24.

Found some older documentation, and it seems this was present even in the days of R18 (probably earlier).


Still, why is Python engine only complaining about this since S24?

Hi Daniel, this was updated during S24, to match C++ convention.

We will update the documentation for the parameter (should be inith). Thanks for pointing it.


Hi Maxime,
But what about the TypeError in the Python console. It seems to expect "initw" ?

According to C++ docs the AddSeparatorH takes a initw, and AddSeparatorV takes a inith.

In my Python plugins I would thus expect to need an initw from S24 on, and an inith for R23 and previous releases (for the AddSeparatorH)

Sorry I was not clear but AddSeparatorH expect initw and AddSeparatorV expect inith in S24 like in C++.

I will fix the Python documentation.

Thanks for the initw confirmation.

I have a same issue. The problem solved by assigning argument without name:

self.AddSeparatorH(5, flags=c4d.BFH_FIT);

Checkout my python tutorials, plugins, scripts, xpresso presets and more