SOLVED No scrolling, no paging...?

Maybe it's just me, but since the reboot, the scrolling stops after half a page on the topic overview lists, not showing any older entries. There is no option to switch the page either.

On the search result list, there is a paging control on the bottom of the page.

Newest Firefox, Windows 10...

Hello @Cairyn,

could you clarify what you do mean with "topic overview lists"? I assume you mean for example the recent topics overview? The content for these has always been loaded in dynamically while scrolling down.

It works for me, both on Edge and Chrome on Windows 10. I do not have Firefox. Have you checked your JavaScript settings for the site?

If you prefer pagination, you can turn it on in your profile under settings/pagination.


Ah, yes, switching on the pagination in the settings seems to help, at least I can now page through the content again.

The dynamic load just doesn't work (it did fine in the previous iteration). I activated the JavaScripts as far as NoScript shows them, but to no avail. The page just doesn't update and ends in the Privacy | Imprint links at the bottom, with no way to continue.
With pagination, the page links appear directly before that.

The effect is the same on all overview pages, not just the Recent one - every category like e.g. "Plugin Development with Cinema 4D" behaves like that. The single topic pages with the actual messages work fine as far as I checked.

What's more, today the page - any page, including the settings! - started to bother me with what appears to be old topic answers of mine, which I may originally have discarded. The bottom half of the page is covered with the dual message edit fields, and a discard/post button pair. It cannot be removed despite an arrow icon that looks like it might move the content, and covers the actual page content. I was forced to click discard on each - I hope that didn't discard any actual messages that I have sent in the past (I have no way of knowing, the GUI doesn't show me a link back to the thread). Quite strange.

I just tried Edge out of curiosity, without login though. Same effect, no dynamic load. Since I don't use Edge normally, I don't have any adblocker/noscript/ublock installed there, just the basic stuff M$ unloads on my system.

Hi @Cairyn, I've tested on different OS (macOS, Windows, Linux) and different browsers (Safari, Edge, Firefox) and, although I've spotted some other issues, I'm capable to dynamically scroll down like in an infinite scrolling mode.

The infinite scrolling mechanism although has a little lag that is "physiological" and can't be avoided: once reached the end of the scroll give the browser a little to refresh and load further pages.

What instead I'm still trying to fix is a sort of "infinite flickering" issue as visible below

I'll try digging down and for the time being as suggested by @ferdinand the best way to avoid this UX flaw is to active pagination under the User Settings

@Cairyn: thanks to nodeBB folks, the issue of infinite scrolling / infinite flickering should be resolved now.

Please let me know if it persists on your side, R

@r_gigante yep, thanks! The infinite scrolling is working now. (I'll keep using the pagination nevertheless... infinite scrolling is one of these "modern" concepts I can do without... 😊 )

The flickering happened for me only when I have the scripts for blocked; when I allowed that, the issue disappeared (don't ask me though why a captcha script that doesn't even execute at that moment would have such an effect).

Pagination settings! So good. Welcome back my little numbered friends.