Plugin not loaded in R23 on macOS

Hi Ferdinand,

sorry for the misunderstanding. With a DEBUG version I just meant a *.pyp file that simply prints something to C4D's Console, but at the client side there is nothing happening at all.

Sorry, that I can't give any more details I'm also pretty much lost here....


@zipit said in Plugin not loaded in R23 on macOS:

just for confirmation: You are on Python, right? Using the try button, I only see Python code in the archive.

And yes I'm using python.

Hi @lasselauch,

no need to be sorry, we just discussed your posting and were not quite sure if you are actually on Python, since debug mode is usually something which is more a C++ thing (although Python technically also has one).

There is also personal information in your screenshot, not sure if you are at liberty/willing to expose this. You might want to consider removing the screenshot or censoring relevant parts if not.

FYI: It will probably take us some time to investigate this.


MAXON SDK Specialist

Thanks @zipit,
happy about all thoughts and ideas...

Hin @lasselauch, with regard to the issue mentioned it looks like it's somehow similar to what has been already reported on this thread and based on customers feedback, it seems that wiping out and reinstalling Cinema solved the issue.

However it's important to note that Cinema 4D R23 is supported on macOS 10.14.6+ or higher, and in this case the minimum requirements are not matched.

Cheers, R

Oh, nice that is something to work with..
I'll try to contact the customer with that info!

Thanks, @r_gigante

Just FYI – I just double checked both customers are running Mac OS 10.13.6

I have the same problem on PC. Using the Drive! 2.0 plugin.

What's happened.
I had it installed in R23 previously and was working before.
I uninstalled R22 and R23 because DAZ3D released their Bridge to C4D
After I installed R23 again, I went to check and the plugin wasn't there. I have tried reinstalling and that is where I am at.

@r_gigante Ah hell. Guess I need to delete EVERYTHING. Allora, tuo inglese... tu parli inglese benissimo. Bravo. Mi, in Italiano non sono bene.

Python plugins do not work reliably in R23 on OSX 10.13.6. The C4D minimum spec is for 10.14.6 as Riccardo mentioned.

And even if you try to debug a plugin on 10.13.6 what you will notice is that many calls (such as print) don't even work on this OS. So you can't even write anything out to the console to see what the problem might be.

No amount of re-installing C4D will help you at all. You just have to let your customers know that the minimum spec for R23 is 10.14.6 and not guarantee any support for anything below that spec.