Python Effector not working with Fields



  • Hi, I have some python effector code created in an older version of C4D and it still works and looks great in the viewport on the current version(R23) but it renders in the picture viewer as if there is no falloff. I'm positive this is due to switching to fields from the old way of using falloffs. How do I get the python effector to respect fields?

    I attached the python effector example taken straight from the C4D SDK. It rendered in the picture viewer fine until I upgraded the falloff method to fields and then it renders in the picture viewer with no effect from the falloff? I imagine it has to do with the SetArray command at the end?

    py_effector_shape.c4d



  • hi,

    Thanks for reporting. This is known bug that have not been fixed yet.
    Unfortunately, there's nothing you can do.

    Cheers,
    Manuel



  • Hi:

    @Motion4D @m_magalhaes

    The solution is very simple. The subset of the clone generator is set as a blank object.Create a new matrix generator, select the object mode, and put in the clone generator.Create a new clone generator, select the object mode, put in the matrix generator, and finally subset the original clone generator again as a subset.But this can lead to delays.

    1644.jpg



  • hi,

    @x_nerve, i might be wrong but i was able to only render when I render a single frame. If a render an animation, i'm back to "no falloff"
    could you share a scene if it's working on your side ?

    By the way, when i'm saying there's nothing you can do, i was talking about using the python directly.
    Of course, you can just use the "Mograph Cache" to bake your cloner animation, that will be saved inside the tag. So at render time, it will use the cache and not the python tag calculation.

    Cheers,
    Manuel.



  • @m_magalhaes @x_nerve Thanks for the update and workaround solutions guys! Hopefully fields can be implemented natively soon!



  • Hi,

    without further feedback, we will consider this thread as solved by Monday and flag it accordingly.

    Cheers,
    Ferdinand


Log in to reply