Solved R21 Project Tool?


I'm trying to get into C++. Haven't touched it before.
Currently, the project tool is made for R23. You can check it here:

Is there a R21 version? Currently, it gives me an error when I run the .sln file.

See error below:


Go to the downloads page and scroll down to R21


Thanks for the response. But for some reason, I still get the same error as before: ("unavailable") and also this:

I guess I'll just have to install the 5GB C++ environment variables for it to work.

@bentraje It's not five GB environment variables, just libraries.

Anyway... Did you put the framework in the right hierarchy? I had to copy the huge thing in several places for the various projects (one for the sample plugins, one for my own, one for the R21 stuff... etc)

This is how my hierarchy looks like:


I got the samples in the newest version from github. The needs to be installed from the C4D installation. (But that's what the original documentation in the other thread says already...)

"Unavailable" sounds as if the framework is not yet installed or cannot be found. If the VisualStudio C++ wouldn't be completely installed, I'd expect compilation errors, but not missing frameworks?


you are missing the desktop development environment for C++, see screenshot below.

Clipboard 2.png

To modify your installation, go to your start menu and type in Visual Studio Installer, if it does not show up, you can also download via the update function in the help menu in Visual Studio.

In the installer click on more/modify on your installed Visual Studio distribution:

Clipboard 3.png

This should bring you to the screen above. The component itself is only a few hundred MB large.


MAXON SDK Specialist


thanks a lot @Cairyn and @zipit for your answers, they are always appreciated.

Of course you need to download some development environment to be able to build application/dll.
Once it's done you don't need to redownload it.

The file must be unzipped in another directory than c4d's main folder. Otherwise, you could face some permissions issue.

We need to improve our documentation.


MAXON SDK Specialist

MAXON Registered Developer

@Cairyn @zipit @m_magalhaes

Thanks for the detailed response. After installing the C++ environments, it works as expected.
Sorry new to this. As I only have python to reference for.

I also managed to build the plug-ins using this guide: