Our plugin is not showing up on the menu in just a few cases.


I write on behalf of Next Limit as we have created a plugin to integrate Maxwell Render inside Cinema 4D.
In general terms, it's working fine, however there a few cases in which the plugin doesn't show up on the menu.
There are only 4 cases. 3 of them happen on Windows 10 with Cinema R21.207 and the other one on Mac Catalina 10.15.2 and with Cinema S22.116.

We are quite clueless about what could be causing this in just these few cases. Do you have any idea about what could motivate this?

Thanks a lot!

Hi Fernando, thanks for reaching out us.

Can you elaborate more on these cases? Under what conditions they happen? Can you reproduce the issue with a simple test plugin? Do the cinema4dsdk plugins shows the same behavior? Have you tried to see if anything weird is reported on the Terminal Console (g_console=true) ?

Without further information we can't be of any real help since nothing is reported in this regard on our bug tracking system.

Cheers, R

Thank you R,

A big part of the problem is that we cannot reproduce it here, under apparently the same situation. I have the same versions here to test and the plugin is working just fine. One of the users has Cinema in English, one in Italian and two in German. I have tried to add Italian and German language packs but it didn't make a change. Other extensions like Google Zync, Substance Engine or Houdini Engine show in the Extensions menu in the failing cases. De normal Console is not showing anything special (I'm not sure if that's the one you ask about). I'm sorry, if I don't give all the information; I'm not the developer myself. I have asked the developer to check the post; maybe he can give more information.


Hi Fernando, feel free to have the developer writing directly to our sdk support email box.

Best, R