GeDialog shadows

  • Hi,
    While prototyping a new plugin, I accidentally noticed that a GeDialog does have a small shadow around it. On Windows 10 this is barely noticable, on macOS (Mavericks, Sierra, High Sierra) it is more obvious.
    I understand that the shadow is an OS related feature, and not controlled by Cinema.
    However, the reason I accidentally noticed this is because when opening GeDialog using DLG_TYPE::ASYNC_POPUPEDIT there is no shadow at all on Windows 10, in contrary to a dialog with menu bar and window frame.
    While on macOS the shadow is always present, no matter the dialog type.
    I haven't looked further in details, but it seems the popup menu also do not show any shadows on Windows 10, while I didn't check what happens on macOS in this regard.

    As such I was wondering if there was a way to prevent shadows from showing up on macOS using specific dialog settings, same as what happens on Windows 10? Or if this behaviour on Windows 10 is just an undocumented feature?

  • Hi,

    this is a 'feature' of Windows: It will render frameless windows without a drop shadow by default. Unless MAXON went out of their way to unify the drop shadow behaviour of the different platforms, I am afraid there is no (easy) way to do this. Technically you could probably try to get the handle for that window and then turn the drop shadow on, but this is very likely hard to do as all GUI stuff on Windows that does not utilise the intended frontend interfaces.


  • hi,

    as this is not related to the API itself, i've opened a Bug entry


  • Just to clarify ...
    I am not trying to get the shadow to show up in case of frameless windows, I am more after a solution to be able to get rid of shadows for frameless windows on macOS as well.