SDK examples at Linux



  • Hello
    Any specification for project tool to Ubuntu 18(04)?

    I use SDK from Cinema4D S22 and 20200416_cinema4d_s22_project_tool.

    There are frameworks libs, but get errors for cinema4dsdk and etc. 🤕

    testsdk_s22.png



  • Hi @iluxa7k , thanks for reaching out us.

    With regard to your question there are a couple of notes explaining the failure:

    • compiling plugin on Ubuntu is at the moment not officially supported (sdk.zip is missing in the archive)
    • the gcc supported version is GCC 6.3.1 as from the VFX reference platform.

    Best, R



  • Hi @iluxa7k , thanks for reaching out us.

    With regard to your question there are a couple of notes explaining the failure:

    • compiling plugin on Ubuntu is at the moment not officially supported (sdk.zip is missing in the archive)
    • the gcc supported version is GCC 6.3.1 as from the VFX reference platform.

    Best, R



  • @r_gigante said in SDK examples at Linux:

    compiling plugin on Ubuntu is at the moment not officially supported (sdk.zip is missing in the archive)

    Ouch, i saw that. I copy from windows. And change project settings to Linux builds



  • There are successful builds at CentOS-7.8.2003 by gcc (GCC) 7.3.1 20180303 (Red Hat 7.3.1-5) But i use project tool for R20. Last project tool(S22) asks me libprocs 6. At Ubuntu - normally

    CentOS7.png


Log in to reply