Export Issues (FBX / DAE)

As a follow up to this thread
https://plugincafe.maxon.net/topic/12042/clone-texture-tag-to-children-while-preserving-coordiates/11
I'm posting here some general export issues :
I only worked with the DAE and FBX exporters, can't say anything about the others

The behaviour is not that clear to describe,
but yesterday i finally understood a main part of what is happening:

By default Texture tags are set to UV Mapping and in Cinema4D
the behaviour is so, that this is not a problem, unless you use a texture.
In reality that leads to many tags used with UV Mapping, because
for things like glass, uniformly colored objects etc this is not a problem.

If you export to DAE and FBX the Texture Tags need to get added
to all actual geometry objects, inheritance from parent nulls probably does not work here.
Now if these objects do not have UV tags the inherited materials are ditched/lost
with the result that loads of objects are not materialized anymore.

It also seems that DAE simply doesnt inherit Texture Tags with UV Mapping
down to the children. (Even if they have UV Maps) But It does with Cubic Mapping.

All in all this is a pretty big mess and I am surprised that this was not addressed, yet.

I had a 1+ GB file with thousands of objects and a manual fix was out of question.
The only solution to export it was to:

  1. copy all parent texture tags down to the actual geometry (with correct projection/scale/rotation) see here :
    https://plugincafe.maxon.net/topic/12042/clone-texture-tag-to-children-while-preserving-coordiates/11
  2. for all objects not having an UV Map, set the projection to Spherical

My solution worked ± for my export, but it is by far not covering all cases.
ie. Cube Object has no UV Tag, but will have after being converted to polygons by the exporter. etc etc

All in all I think... these Exporters really miss some love ;)

best, index

ps. Test Files attached
Export1.c4d Export2.c4d

Hello,

We've talked about this issue in our morning meeting. Contrary to what I've said, it's Core related and not API related. (limitation of cinema4D itself in fact)

You have to open a ticket in our support. Tell them you are coming from our forum and it's not related to the API and it's a Core Problem.

Sorry for wasting a bit of your time but we need to keep organized.

Cheers,
Manuel