Solved R21 Trial: Does it load plugins?


short question, as I couldn't find information about this for R21: Does the R21 Trial load plugins?

Thanks & greetings,
Only asking personal code questions here.

Hi Frank, thanks for reaching out us and yes, it does!

As a side note, that yesterday I forget to mention in the rush on answering back, please be aware that Cinema 4D R21 executables are not differentiated anymore as it was in the past between demo and non-demo versions.
The binaries are exactly the same and are those stored on the Maxon website and the sole difference is the license used by Cinema. The trial license is actually just a regular license but time-limited.

Best, R

Hi Ricardo,

thanks for your reply!

The thing is, we have several machines, and Cinema R21 works fine everywhere. On one Machine (Win 10), which runs a Trial license, the plugins do not load. The code in main.cpp is never called. Another machine, which has exactly the same configuration and the same version of Cinema installed (just not a Trial), the same plugin binary works perfectly.

The old "delete prefs/symbolcache and directorycache" trick does not work either. Full access permissions are granted in all Cinema folders and subfolders.

Any ideas what else could be the reason?

Only asking personal code questions here.

Hi Frank,

I've just created a temp account to which a Cinema 4D R21 trial license is bound to and actually I experience no issue in loading the cinema4dsdk examples plugin.

Could you please provide your plugin (even via email to sdksupport)? Or could you reproduce it with a simple code? Are you sure that the two machines are sharing the "exact same" configuration?

Thanks for following up.

Thanks, Ricardo!

I'll ask my colleague (who's experiencing the issue) if he can provide something :+1:

Only asking personal code questions here.

But no plug-ins in R21.207 (demo version) possible?

The LAZPoint plugin from would be a nice thing for me if it works for me. But it has to be installed on Cinema4D-R21, with r22 or r23 it doesn't work.
To test it, I want to run the LAZPoint demo plugin on a demo version of Cinema - r21. R21-Demo is already running and the LAZPoint-Demo-Plugin is already in the directory C: \ C4DPlugins and I have registered this directory in the program defaults of R21.

But it doesn't work. Other plugins that are trying to be loaded also do not run, none of them run. Tried on 2 computers (Win10 64 pro and win 64 home).
What's wrong?

----- Orginal in german:

Doch keine Plug-Ins in R21.207(Demo-Version) möglich ?

Das LAZPoint-Plugin von wäre eine feine Sache für mich, wenn es bei mir läuft. Es muss aber auf Cinema4D-R21 installiert werden, mit r22 oder r 23 geht es nicht.
Um es zu testen, will ich das LAZPoint-Demo-Plugin auf einer Demo-Version von Cinema - r21 laufen lassen. R21-Demo läuft bereits und das LAZPoint-Demo-Plugin liegt bereits im Verzeichnis C:\C4DPlugins und ich habe dieses Verzeichnis in den Programvoreinstellungen von R21 angemeldet.

Es läuft aber nicht. Auch versuchsweise ebenfalls zu ladende andere Plugins laufen nicht, keines läuft. Auf 2 Computern versucht ( Win10 64 pro und win 64 home) .
Was läuft falsch?