ProjectTool problems in MacOs Catalina

  • Hi,

    I recently upgraded to the latest MacOs Catalina (10.15) and can't seem to launch the ProjectTool to generate XCode projects. I'm new to C4D plugin development and haven't tried it on previous MacOs versions.
    I have C4D R21 and corresponding ProjectTool.

    Any ideas?

  • hello,

    maybe a quarantine issue. Just to be sure.
    can you download the zip file and before unzip it apply this command on a terminal (go to the folder where you downloaded the zip file first.

    xattr -d ""

    You have to wait a bit and no message will be displayed if there's no error.

    After, unzip the file and try again.


  • Hi @m_magalhaes , thanks for getting back to me so quickly!

    I've tried running xattr -d "" on a freshly downloaded zip file, unpacking it and running the kernel_app mac application and still get the same error:
    "The application 'kernel_app" can't be opened".

  • update: I have extracted the zip archive with the project tool on another Mac running MacOs Mojave and then ran it in Catalina and that worked. So I guess it's some funky security measures of MacOs Catalina that won't allow project tool to run.

  • Hi c4dmac, thanks for following up here.

    With regard to the issue you've reported you can get fixed by reestablishing the executable bit on the kernel_app file found in the zip archive.
    To sum it up, upon downloading the project tool archive you have to:

    • remove quarantine
    xattr -d "" ./
    • extract the archive (either via terminal or via finder)
    unzip -d ./cinema4d_r21_project_tool_20190903 ./
    • re-establish the kernel_app executable bit
    chmod 555 ./cinema4d_r21_project_tool_20190903/

    Best, Riccardo