R21 SDK build error



  • If you build R21 SDK as it is in VS2017, an error will occur and you will not be able to build.

    1> Looking for source files in C: \ sdk21 \ frameworks \ core.framework ...
    1> register.cpp
    1> c: \ sdk21 \ frameworks \ core.framework \ generated \ hxx \ interfacetemplate2.hxx (209): error C3861: 'PrivateGetInstantiationId': identifier not found
    1> c: \ sdk21 \ frameworks \ core.framework \ generated \ hxx \ interfacetemplate2.hxx (209): error C3861: 'PrivateGetInstantiationSourceName': identifier not found
    1> c: \ sdk21 \ frameworks \ core.framework \ generated \ hxx \ interfacetemplate2.hxx (213): error C3861: 'PrivateGetInstantiationId': identifier not found
    1> c: \ sdk21 \ frameworks \ core.framework \ generated \ hxx \ interfacetemplate2.hxx (400): error C3861: 'PrivateGetInstantiationId': identifier not found
    1> c: \ sdk21 \ frameworks \ core.framework \ generated \ hxx \ interfacetemplate2.hxx (400): error C3861: 'PrivateGetInstantiationSourceName': identifier not found
    1> c: \ sdk21 \ frameworks \ core.framework \ generated \ hxx \ interfacetemplate2.hxx (404): error C3861: 'PrivateGetInstantiationId': identifier not found
    1> Build of project "core.framework.vcxproj" finished-failed.
    

    The Project Tool used was the Project Tool for Cinema 4D R21, and the sdk.zip that came with R21.026 was used.

    How can this be solved?



  • Hi Anoano, thanks for reaching out us.

    With regard to the issue reported, we've discovered no issues in compiling the SDK coming with the corresponding Cinema version.

    Can you please list the detailed steps you've done to let us reproduce the issue?

    Best, Riccardo



  • thank you for contacting.
    Here are the steps I took:
    My environment is Windows 10 & Japanese & CINEMA4D R21.026

    1. Download Project Tool for Cinema 4D R21 and place it under C drive
    c: \ project_tool21
    
    1. After installing R21, extract sdk.zip under C drive
    c: \ sdk21
    
    1. Run the command to move to the Project Tool at the command prompt
    kernel_app_64bit.exe g_updateproject = c: \ sdk21
    
    1. Open plugins.sln and start VS2017
    C: \ sdk21 \ plugins \ project
    
    1. Retargeting the solution to change the Windows SDK version to 10.0.16299.0

    2. Run solution build

    plugins - Microsoft Visual Studio 2019-10-21 16.06.37.jpg

    plugins - Microsoft Visual Studio 2019-10-21 16.07.25.jpg



  • Hi Anoano, thanks for providing the additional informations.

    I've repeated your steps and, unfortunately, I've not encountered the issue mentioned in building the solution.
    So far I've a few questions:

    1. why did you retargetted the projects to Windows SDK 10.0.16299?
    2. are you sure that all the projects (both frameworks and modules) under the solution were all retargetted to the new Windows SDK?
    3. have you tried to compile the project has it is once generated by the projecttool?

    Best, Riccardo



    1. I retargeted because the SDK version was 8.1.

    2. All projects have been changed to the new Windows SDK.

    3. I created a project with kernel_app_64bit.exe of project_tool.

    I built it without changing the SDK version again, but I still get an error around core.framework.

    Isn't it possible to get sdk.zip that can be built normally because it is useless here and there?



  • Hello,

    I'm jumping in just to ask you the Visual Studio version you are using.

    You should use the last 2017 one, we have some issue with older version.
    Like compile not working with version v15.7.4 but working with v15.9.17

    Cheers,
    Manuel



  • Thanks for your advice.
    The build is complete.
    It was because VS2017 when Unity was installed was old.
    Now you can build other plugins.
    Thank you very much.