plugins folder, now you see me, now you don't.



  • @r_gigante

    Tested again, same results.

    R20.059
    case 2: <user_prefs>\plugins unchecked, D:\R20plugins checked
    -> restart -> no collision

    R21.026
    case 3: <user_prefs>\plugins checked -> no collision.
    I really don't get this as I remember having had collisions when I first tried this.

    I have tried following:
    Removed all paths from the preferences, restart Cinema 4D. Obviously, plugins are loaded due to the default folder, and no collisions since no other path is defined.
    I then add the <user_prefs>\plugin folder again, checkbox enabled. Restart -> no collisions.

    Went a step further:
    I had the <user_prefs>\plugins folder added, then added the <user_prefs> folder (without the "plugins" subfolder) -> restart -> no collision

    Went even crazier:
    With above 2 paths available (and enabled), I added D:\R21plugins
    -> restart -> collisions !!!

    Final case:
    removed the D:R21plugins, then copied the plugins in the <user_prefs>
    resulting in
    <user_prefs>\plugins
    <user_prefs>\plugins - Copy
    Added both paths to the preferences, both enabled -> restart -> collisions
    Removed the copy path from the preferences keeping only <user_prefs>\plugins
    -> restart -> no collision

    Cannot explain the behavior.

    I think I will stop the whole topic here, it seems to make no sense at all.



  • I'm sorry Daniel you're giving it up here, but I dunno how I can be of any further help. I will ask today to one of the other members of the team to replicate the same steps on his system to see if they are consistent with my findings or yours to grant information correctness for those coming in the future and reading the post.

    Best, R.



  • hello,

    I've tested with R20.059 and 21.026 and the behavior are the same than @r_gigante. (we talked about it to be sure)

    Cheers,
    Manuel



  • @r_gigante
    I am not actually giving up, just mentioning that it doesn't seem to make sense pursuing with this topic. As it seems we're not experiencing the same behaviour, as if we're using a different version (although it seems to be the same version number) or we're performing different actions.

    Now, I added a new plugin and could not reproduce my previous result with R20.059, as it now always seem to collide whatever I try.
    However, with R21 -which was mentioned should always collide- ... well now I get no collisions. According to the printscreen I made you can notice the only path added to the preferences is the <user_prefs>\plugins, exactly the same as the "internal default", still the console shows no collisions.

    According to both of you, this is not reproducible at your end. Still I am getting this result. I must then have done something differently than both of you?
    Note, the screenshot is right after launching Cinema 4D, and opening the console window and the preference window. No changes performed, simply opening the windows.

    R21 plugins not colliding.png



  • hello,

    with the same parameters, I got collision. Would it be possible to test with our sdk ?
    (it should not be different but at least you would test with the same plugin than us)

    Cheers,
    Manuel



  • @m_magalhaes

    I have built the sdk samples and copied the res folder and the created xdl64 file into
    C:\Users\Daniel\AppData\Roaming\Maxon\Maxon Cinema 4D R21_64C2B3BD\plugins\sdk

    Starting Cinema 4D without any paths in the preferences and plugins get loaded. No message in the console.

    Then adding the path:
    C:\Users\Daniel\AppData\Roaming\Maxon\Maxon Cinema 4D R21_64C2B3BD\plugins
    to the preferences, restarting Cinema 4D ...
    Plugins get loaded, no message in the console window. Thus no collision.



  • Hi Daniel, thanks for following up again.

    Just to be sure nothing get's neglected I've recorded a video showing that also doing your steps is consistent with what me and Manuel have reported with regard to R21
    You can see the video here.

    Best, Riccardo



  • Thanks for video.
    I have a slight suspicion about the reason we have different results. Similar to that other discussion point about memory leaks that you guys also can't seem to replicate.
    But to figure this all out I will need to purchase some extra hardware ... might take a while before I get the funds collected. I will then report back, in both topics.



  • I now have upgraded the original laptop which was running R20.057, and now have Windows 10.
    As such with a clean install, I have now R20.059 installed (clean, not updated) and R21.026 (also clean, not updated from 21.022).
    Both versions have plugins installed in the <user_prefs>/plugins folder. Without any path added to the Cinema 4D preferences they both load the plugins as is.

    For testing purposes I have added the path to this folder in both releases.
    With R20.059 I get collisions, which I didn't get with R20.057 on this same laptop running Windows 8.1
    With R21.026 I do not get collisions

    I thus experience the same results as those I had with the original installs on "the NUC" (see the memory-leak topic). I had hoped the results would be different, as was clarified by the memory-leak topic, but alas the presence of a dedicated/discrete graphic card has no impact on the result this time.

    But still, I now have 2 machines which both have clean installs and provide same results as to collisions/no-collisions, and still contradict the results you both have experienced. And this for both R20.059 and R21.026.

    I am not sure were to go from here?



  • hello,

    I confirm it's strange.

    Could you use the g_console=true and g_logfile=d:\logfile.txt as said in this page
    (both will contain the same lines)

    Send us the logfile (sdk_support@maxon.net) if you don't want to share that in public.

    Cheers,
    Manuel