Python c4d.CheckIsRunning(type) returning None



  • So the c4d function c4d.CheckIsRunning(type) is supposed to return a True or False depending if the given type is running.
    Yet no matter how often I run it, I'm always being given back the same thing, None.

    Not True or False, but no return at all, it's as if the function is not actually executing anything but instead doing nothing.
    Anyone else experiencing this?

    In fact looking further it appears that almost none of the "miscelanious" functions are working as they should here.



  • Hello,
    First, for your next threads, please help us keeping things organised and clean. I know it's not your priority but it really simplify our work here.

    I've added the tags and marked this thread as a question so when you considered it as solved, please change the state :)


    It's difficult to answer your question if we don't have a bit more context. Are you calling that in a script, tag, objectdata etc..
    If you could share, it can be a bug but we need to know how to reproduce it.

    Also what version of cinema4D are you using ? (that's why tags are important for us also)

    Cheers,
    Manuel



  • Hi,

    c4d.CheckIsRunning() seems to work just fine. As Manuel pointed out, the context is important. When invoking the method in a threaded context the results might not always be what you expect them to be.

    Here is a very small example for a Python Scripting Tag:

    import c4d
    #Welcome to the world of Python
    
    def main():
        check = c4d.CheckIsRunning(c4d.CHECKISRUNNING_VIEWDRAWING)
        print "CHECKISRUNNING_VIEWDRAWING from main(): %d" % (check) 
    
    def draw(bd):
        """
        """
        check = c4d.CheckIsRunning(c4d.CHECKISRUNNING_VIEWDRAWING)
        print "CHECKISRUNNING_VIEWDRAWING from draw(): %d" % (check) 
        return True
    

    Cheers
    zipit



  • hello,

    without any news, i'll pass this thread to solved.

    Cheers,
    Manuel


Log in to reply