Solved Can not compile plugin for R20

Hello PluginCafe,
I am tasked to update one of my clients plugins to R20, which by itself would not a problem.
The problem I am facing is, that the plugin uses a lot of 3rd party c++ libraries that the sourceprocessor cant seem to compile correctly. For R19 everything compiles without problems, I simply changed my plugin code to fit the new R20 sdk (obviously using the Project Tool etc.).

The errors itself are (only in the libraries) "Unexpected EOF" and "Exptected ... ".
Which come from the "Rem IncredBuild_OutputDirTree" command from the sourceprosessor.

I am not too knowledgable in Visual Studio and don't really get why my build fails.
I also already checked that my includes and links are the same as in the working solution of R19 thats why I suspect that it has something to do with the sourceprocessor.

I hope somebody can help!
Kind Regards,

Hi Florian, thanks for reaching out us.

In order to trouble shoot the issue, please provide us with:

  • the error log provided by the compiler
  • the projectdefinition.txt you're using
  • a simple project with maybe one external library to run through a reasonable differential analysis.

Looking forward your further notes, give best.

Hello Riccardo,
in the included file is the error log and projectdefinition file of the actual project I am trying to compile and a example project which throws the exact same error messages using the blitz library.
I hope it is just some stupid thing on my part that I overlooked when using the project tool, but I am really at a loss here.

I had to upload the poject to somewhere else (Google Drive) because it was too big to upload here.

Thank you so much so far!
Kind Regards,


no solution yet here, just some remarks.

I see it's Ocean related, I guess you are dealing with 2D arrays and FFT and so on.

With the R20 there are some functions that could help a lot for that :

For 2D arrays you can use MatrixNxM, for FFT use FFTInterface and as you are dealing with 2D array you can use ParallelImage.

No more need for 3rdParty to create Ocean Simulation.

the last version of blitz can be found here but i still have some issue with it.


MAXON SDK Specialist

MAXON Registered Developer

hello again,

try that, not the cleanest but :

  • get the zip archive from github

  • unzip that archive to Blitz-master directory and unzip also the inside the directory

  • open Blitz-Library.sln project inside Visual Studio

  • if should ask to upgrade the project, so do so

  • activate Release and x64 and Build the solution.

  • On your plugin directory create a "include" sub-directory at the root (not inside source so you should have include, project, res and source directories at your plugins' root)

  • copy the blitz directory (witch is inside the blitz-master) to your include directory

  • in include/blitz/generate remove every file starting with "gen"

use project_tool to update your project and try to compile

It should compile but not sure if everything will work as we remove files 🐷

Let me know.


MAXON SDK Specialist

MAXON Registered Developer

Hello Manuel,
thanks a ton!
I also didn't know of the FFTInterface of C4D, I will defenitely take a look!
I will also try your solution even if it is not the prettiest, if it works, it is better than nothing.

Again thanks a lot so far!
Kind Regards,


this thread will be considered as Solved tomorrow is you have nothing to add.


MAXON SDK Specialist

MAXON Registered Developer