SOLVED urllib2.urlopen fails on C4D for Mac

Hey Lasse,

sorry - removing "repos" is actually wrong when using api access, my bad.
I can now also comprehend your problem. I'm going to dig a little deeper. 😉

Hey again. Managed to download it when using the zipball or tarball URLs. Weird though, that it responds with 415 when using the asset id directly.

@mp5gosu interesting... i guess shipping and importing the requests module with the plugin, is too much of a hassle... really hard to find any further informations on this... strange...

I dare to say that urllib2 is the culprit here. I don't have any problems using other libs or tool in the exact same way. curl works out of the box for example.

yeah, had no luck either... okay, so I'm probably back to importing requests as 3rd party module. 🙂

Thanks for the quick help, Robert!

Using requests package would be the solution I guess. Even the docs state that they are auperior on high level access.
The web says that urllib2 is broken in so many ways due to its age.

Hi @lasselauch as @mp5gosu this is a urrlib2 issue and we can't provide support on this topic.
Moreover, if you have more questions (while I think everything is said), please open a new thread since while the overall topic is related, the question and issue are different.

Cheers,
Maxime.

The issue with the certificates still persists in R21.022 on macOS 10.13.6.

Cheers,
Frank

@fwilleke80 thanks for bumping it, I will bump this topic when the issue will be resolved.
For the time being, my workaround provided previously still work.

Cheers,
Maxime.

R23 still has the same Error

Hi @pyr this shouldn't happen on R23.
Can you confirm your exact Cinema 4D version (located in help->About in the bottom you do have the full build number)
Your Os and OS version.
The code used and the error returned.

Thanks a lot,
Cheers,
Maxime.

I had a question too partially related to this one.

I was using urllib2 to access a payhip product page of my own, so that when I use my VersionReader Node in XPresso, it can access the current preset version code present on my product page. For some reason, when I try to open the webpage, it ends up not working. It has no feedback reply as well. I had it on a try-except block so I don't knoe what is the exact error (yet)

However, I can access my github webpage for the build code, so having a solution for this is not really needed for my side (my friend does not have a github page so we kinda need to have a workaround)

I was using R19 for this set of scripts.

Hi @SolarPH please open a new topic with your code and the exact error.

Cheers,
Maxime.