"Signed Integer is greater then maximum" when registering python plugin



  • Cinema is complaining about this line of code in my RegisterObjectPlugin function saying "Signed Integer is greater then maximum":

    info=c4d.OBJECT_GENERATOR | c4d.OBJECT_ISSPLINE)

    I even referenced a working spline plugin and it's the same.
    I tried looking the error up and I still have no idea why it thinks this is an issue, any ideas?



  • Can you post the context (some lines before and some lines past)? The line as posted makes no sense, there is a closing bracket without opening...



  • Hi,

    as Cairyn already said, you will need to provide us with a bit more code. My assumption is, you get pointed to this line by the error code, but it is probably the plugin registration broken into several lines (as we also do in our examples). In this case the error can be in all lines belonging to the same statement.
    If I should do an educated guess, could it be you made up a plugin ID yourself from random numbers, instead of one from Plugin Café (no worries, we probably all do during testing, although it's of course not recommended)? Does it still fit into a 32-Bit integer?

    Cheers,
    Andreas



  • @a_block It was the ID. I did use a random number, apparently one too many. I didn't think it would matter for testing but I guess I was wrong! I figured it would be something dumb like that. It was just weird it pointed me to that line for the error. And yes sorry my code snippet was confusing, I thought it was standard practice to put RegisterObjectPlugin on multiple lines for easier reading.

    Thanks again!


Log in to reply