Can't open project file in XCode



  • I followed all the steps in the Maxon instructions to try to re-compile an old plugin for R20.
    After running the Project Tool, I get a project file inside my project folder.
    But when I try to open the project file in Xcode, I get the following message:

    Project /Applications/MAXON/R20/sdk/plugins/CMYK/project/cmyk.xcodeproj cannot be opened because the project file cannot be parsed.

    What could be happening?



  • Are you using XCode 9?



  • Yes, I', using XCode 9.4.1


  • Global Moderator

    Hi rui_mac, thanks for reaching us.

    With regard to the issue mentioned here, considering this other thread where you seem able to compile on Xcode, are you still experiencing the issue?

    If the issue persists, can you please provide information about the projectdefinition.txt file you're using to generate the project?

    Best, Riccardo



  • The other thread relates to a different plugin.
    I tried with two of my c++ plugins, first.
    And the one giving me this problem, is the simpler one.
    The projectdefinition.txt file that I'm using for this plugin is exactly the same (except the ModuleId, of course) as the one I'm using for the other plugin that is compiling (actually, not compiling, due to that error related with symbols). But, at least the project file is opening.
    Here is the content of my projectdefinition.txt file:

    // Supported platforms
    Platform=Win64;OSX

    // Type of project
    Type=DLL

    // API dependencies
    APIS=image.framework;cinema.framework;mesh_misc.framework;math.framework;crypt.framework;python.framework;core.framework;command.framework

    // Enable some advanced classic API support; not needed for hybrid plugins
    C4D=true

    // Plug-in code-style check level
    stylecheck.level=0

    // Custom ID
    ModuleId=com.ruimac.cmykc4d

    Since I don't know how to determine what APIS my plugins depend on, I added all, I confess.



  • I have been re-creating the project file over and over again with the Project Tool and I still can't open the project file in XCode ☹



  • I found the culprit. My cmyk.cpp file was inside of a folder. When I got it out and placed it alongside the main.cpp file, the project file created by the Project Tool finally opened in XCode.
    Now I'm getting other errors, but at least the problem reported in this post is solved.