Solved Memory leak after plugin migration R16 -> R20

Windows 8.1 running Cinema 4D Studio R20.030 (RB257898).
Just started C4D from Visual Studio (2015).
Default scene, with Live Selection tool active.
No objects, no materials, no plugins.
Didn't do anything in Cinema 4D, then just closed the application.

R20 was installed without content, only program and help documentation.
The only thing I did after clean install, was set the "Highlight new features" in preferences to "Off". Select the Live Selection tool and then "Window > Customization > Set as Default scene".
I also have created a few custom palettes and saved the custom Layout as startup Layout.

Apart from this, the install is clean ... and never used, apart from starting from Visual Studio to test out some CommandData/GeDialog plugins.

Hi C4DS, unfortunately, I'm still not able to reproduce it, is it possible for you to share the Layout and Palette File?



I deleted all layouts, deleted all preferences, removed the new.c4d file.
All, except the installed updates. My Cinema 4D install should now be equal to a fully clean install.

Still have that same oneliner memory leak just starting Cinema 4D from Visual Studio 2015 (Express), and closing application without performing any action.

Not that this is any help, but I'm currently also looking into some other memory leak issues and I get the same leak when running a clean Cinema R20.026.

First of all, happy new year to both of you.

Regarding the issue, thanks a lot for confirming it, despite I'm still not able to reproduce it. I will ask you to wait until my other colleagues come back from their well deserved holiday to do more tests on this topic.


Hi Daniel, thanks for following up.

I've tried to match as much as possible your devenv but I confirm what reported by @m_adam and I can't replicate the behavior.

My setup is:

  • Windows 8.1 version 6.3 (Build 9600)

  • Microsoft Visual Studio Express 2015 for Windows Desktop
    Version 14.0.25431.01 Update 3

  • Microsoft .NET Framework
    Version 4.7.03062

  • Common Azure Tools 1.8
    Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

  • NuGet Package Manager 3.4.4
    NuGet Package Manager in Visual Studio. For more information about NuGet, visit

  • SQL Server Data Tools 14.0.60519.0
    Microsoft SQL Server Data Tools

I apologize for not being more helpful but without a more detailed scenario letting us to replicate the issue we can't be of any further help here.

Best, Riccardo

Hi Riccardo,

I have all the same version as you mentioned except for .NET
I am currently on 4.7.02558

Hi Daniel,

I'm actually running out of ideas here. Can you try to install Cinema from scratch in a different folder and see if it the behavior persists?

Cheers, Riccardo

It will take a while before I find the time to install from scratch.
I am in the middle of a project, and don't want to risk anything on this machine right now.
But I'll leave the topic open for now and come back when I have more to report.

Thanks Daniel, look forward your further tests.

Best, Riccardo

Have finally got the chance to install from scratch. But I didn't try with the original install, and upgraded directly to R20.057 before testing. Could not reproduce the problem on this new install.
However, the problem persisted on the other installed R20.030.
I updated that version as well to R20.057 and with that the memory leak cannot be reproduced anymore.

I am setting this topic to solved as the update seems to fix the issue.

Thanks a lot Daniel for following up here.

Glad to listen that the update actually fixed it, although even on 20.030 I had no better luck to reproduce.

Best, Riccardo