SOLVED Plugin crashes on Windows 10

Hello PluginCafe,
so I have been developing a plugin for a client and we recently stumbled across a VERY strange issue.
First of all, the plugin works completely fine on Windows 7and 8/8.1 no issues there. But on Windows 10 it crashes when you insert the plugin (object data /object modifier) into the scene.
I actually "found" the cause which is in the GUI. I have a relatively large .res file and two parameters crash the plugin. Note: the plugin works fine when commenting both out.

REAL XIOCEAN_OCEAN_RES { MIN 1; MAX 12; CUSTOMGUI REALSLIDER; }
REAL XIOCEAN_OCEAN_RES_RENDER { MIN 1; MAX 15; CUSTOMGUI REALSLIDER; }

These two lines crash the plugin, and I have no idea why. As I said before, the .res file is relatively big and has more real-sliders in it, which work without a problem. In my code I use the same method to initialize and read from the parameters for all of them.
I tried to read/initialize them in three different ways:

  1. Straight forward using the BaseContainer (modifier->GetDataInstance() from the ModifieObject for reading)
  2. With modifier->GetParameter(...) same result.
  3. doing nothing at all.
    I also tried renaiming those parameters and giving them different IDs but it always crashes.
    I had a similar issue once, where I could not load a ImageButton on Windows 7 but all other Windows versions.
    Is there something I missed, maybe a cache file or something that might have corrupted something?
    Becuase at this point I really don't know what I am doing wrong here.

thanks in advance!
Kind regards,
Florian

Hi Florian,

sorry, to hear about this issue. To be honest, I can hardly believe that it's those parameters or sliders causing a crash on plugin registration. I'm more thinking of some memory maybe being trashed beforehand. But in the end, it doesn't matter so much, what I do believe or not or what I might suspect, we want to assist you in solving this riddle.

As we have no evidence for issues in the described area, nor are we able to reproduce it via a simply example, I'd like to ask you for some more information. Could you maybe provide us with a stack trace, when the crash happened? Either from within Visual Studio or via the crash reporter (in the latter case, please notify me here, I need to look out for the report).

I have turned this thread into a question.

Cheers,
Andreas

Hi Florian,

sorry, to hear about this issue. To be honest, I can hardly believe that it's those parameters or sliders causing a crash on plugin registration. I'm more thinking of some memory maybe being trashed beforehand. But in the end, it doesn't matter so much, what I do believe or not or what I might suspect, we want to assist you in solving this riddle.

As we have no evidence for issues in the described area, nor are we able to reproduce it via a simply example, I'd like to ask you for some more information. Could you maybe provide us with a stack trace, when the crash happened? Either from within Visual Studio or via the crash reporter (in the latter case, please notify me here, I need to look out for the report).

I have turned this thread into a question.

Cheers,
Andreas