Crash in class SetUsedFrameworks



  • Hello,

    I have a plugin here. When I run it on OSX in the debugger, I get a breakpoint on C4D startup, in:
    core.framework/source/maxon/register.h, line 38

    module._usedFrameworks = ids.GetFirst();
    

    Running it without the debugger leads to a crash.

    With the Windows build, this does not happen; only on OSX. How can I fix this?

    Thanks & greetings,
    Frank


  • Global Moderator

    Good morning Frank!

    I'm lacking a few information here to assess and help:

    • are you using the ProjectTool to assemble the Xcode project?
    • if yes, can you provide the projectdefinition.txt you're using?
    • can you provide the call stack when the breakpoint is hit?

    Best, Riccardo



  • Hi Ricardo :)

    Thanks for the reply!

    1. Yes, I am

    2. Here it is:
      // Supported platforms - can be [Win64;OSX]
      Platform=Win64;OSX

      // Type of project - can be [Lib;DLL;App]
      Type=DLL

      // API dependencies
      APIS=cinema.framework;mesh_misc.framework;math.framework;crypt.framework;python.framework;core.framework;

      // C4D component
      C4D=true

      stylecheck.level=3 // must be set after c4d=true
      stylecheck.enum-registration=false
      stylecheck.enum-class=false

      // Custom ID
      ModuleId=com.mydomain.mymodule

    3. Screenshot of the call stack
      0_1542197117890_callstack.png

    EDIT: And here's the breakpoint:
    0_1542197270614_breakpoint.png

    EDIT 2: Additional information
    I'm still using OS X 10.11.6 El Capitan, with XCode 8.2.1. Have successfully built other plugins on this machine. C4D version is 20.030 (Build RB257898).

    Cheers,
    Frank


  • Global Moderator

    Hi Frank, thanks for following up with these details.

    As from our Cinema 4D documentation about Development on macOS we only support Xcode 9.x for Cinema R20.x.
    Please try to compile your plugin with a supported development environment and if it fails again we'll look deeper into it.

    Best, Riccardo



  • Hi Ricardo,

    I can't do that, unfortunately. There are several reasons why I cannot update my machine to a later OSX version than El Capitan, at the moment. I did not encounter any problems so far that could be tracked down to the XCode version.

    Btw, I solved the problem. For some reason, after running the Project Tool again in a fuzzy "F*** it, it has has to work!" moment, things started working. I am stumped, as I don't know the reason, but anyway, the problem's gone.

    Cheers,
    Frank