Tell the HTML Viewer to ignore javascript



  • I think the HTML viewer (CUSTOMGUI_HTMLVIEWER) that is built into C4D may be some outdated version that can't handle modern javascript. I have been trying to load in a few pages from the web and it always complains about the javascript on the pages.

    Is it possible to pass in some settings to the CUSTOMGUI_HTMLVIEWER to tell it to completely ignore any errors in the javascript?

    Otherwise what happens is anytime I show a website it pops up the Script Error dialog.

    I have been testing using R20 under Windows, but the issue is also present as far back as R17.

    Thanks!


  • Global Moderator

    Hi Kent,

    the CUSTOMGUI_HTMLVIEWER just uses a standard system widget (I think on Windows falling back to use of the IE) to display HTML pages. Its main purpose is certainly to display our documentation, means to browse arbitrary web pages are probably just a side effect.

    Anyway, maybe you can provide me with an URL to reproduce, then I'd forward this to our development.

    Unfortunately we are not aware of any workaround or means to configure the CUSTOMGUI_HTMLVIEWER in this regards.

    Cheers,
    Andreas



  • Hi Andreas,

    I was just experimenting with viewing some apple pages in C4D such as this one.

    https://developer.apple.com/documentation/arkit/arfaceanchor/blendshapelocation/2928261-eyeblinkleft

    In internet explorer and chrome it works fine. But when viewed via C4D it throws up a scripting error.

    Internally I would guess that C4D is using a standard system widget as you said, but perhaps its targeting a very old version of IE.

    I know its overkill just for documentation, but maybe maxon could look at integrating https://www.chromium.org. I looked at doing this myself a couple of years back.

    I will avoid using any outside websites for now.

    Thanks,
    Kent



  • Just in addition to my last email. I was going to use the same system for connecting to the SketchFab store using OAuth. But if this throws up errors then that will be a no go as well. I haven't tried it yet though. So this is another use case where it would be great to have this widget updated. Authentication via browsers and catching the token in the callback is a vital part of the workflow.



  • One last note. I just tried this on OSX and it works fine. So it is just an issue for Windows machines and whatever version of IE the widget is using.