CINEMA 4D C++ SDK



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/03/2003 at 07:19, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   8.100 
    Platform:   Windows  ; Mac  ;  Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    The new version 8.1 and 8.1 Demo now contain the "ready-to-use" SDK (a separate download no longer is necessary). All problems (regarding line endings etc) should be fixed now!
     
    Philip Losch
    MAXON Computer



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/03/2003 at 08:23, xxxxxxxx wrote:

    Can you elaborate? I updated to 8.1 using the newest updated updater, and when I try to compile the sample C++ project (that contains several different kinds of plugins) I get a compile error in the example custom data type module that says:
    Calculate: Unable to convert parameter 4 from (const CustomDataType * ) to (CustomDataType * ).
    When I fix this - I then get many link errors.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/03/2003 at 09:21, xxxxxxxx wrote:

    It looks like you're either using the broken 8.1 updater or an older SDK version (the error you describe indicates that it is the old 8.012 SDK project).
    Please download the 8.1 updater again. Before you install delete the SDK from your plugin folder (not necessary normally, but to avoid any possible problems). Then install the update - it'll install the 8.100 SDK also. Only use this SDK and project file!
    I've just tested it here under several configs and it works... Please let us know if the problem still exists!



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/03/2003 at 10:08, xxxxxxxx wrote:

    We'll I'll be - I just looked under the "plugin" folder, and you're right - the new updater put in a "cinema4dsdk" directory. Sorry for the false alarm.


Log in to reply