Cannot mark post as answer



  • Hi mp5gosu, thanks for following up.

    As last attempt try to change this thread to "a question" and try to mark one of the posts as correct. Let's see if it works. If not, then I have to dig down and find the cause ;)

    Cheers, Riccardo



  • Hi guys,

    I'm finally glad to state that by upgrading the platform to a more recent version you should be able not only to mark a topic as Solved but also to select the correct post solving the thread.

    Please verify on your side with your next-to-come threads and in case report any unexpected behavior.

    Best, Riccardo



  • Made a question from this topic, still the same. :)
    I am still able to mark the whole topic as solved, but no particular post but my own!

    By the way, I marked the other thread as solved since it is. If you found the cause, I'll mark the correct post as answer.

    Happy finding then! 😅



  • @r_gigante Hey, any update on this? Or can I even do something to help?



  • Still looking into it. I'll let you know asap. In the meanwhile, for your next support topics, please use the Q&A functionality to see if it's limited to that thread or to your user.

    Best, Riccardo



  • Hi, I meet the same problem. And I find that if I want to mark a post as "correct answer", the post must meet all of 2 conditions:

    1. the topic must be in "Unsolved" state.
    2. the post waiting to mark must belong to the user himself/herself, a user can't mark other's post as "correct answer".

    I think this may be related to user group permission.



  • Hi,

    we are sorry this currently does not work as intended for you. We will look into the issue after DevKitchen in November. So long we will try to mark certain answers accordingly, let us know, if we pick the wrong one.

    @eZioPan : Just to be sure: In point 2 you are talking about posts and not the thread, right? Because indeed you should only be able to mark questions in your own thread. But there it should be possible for all posts.

    Cheers,
    Andreas



  • Hi, @a_block!

    update:
    When I search on the forum, I found the normal users aren't belonging to any user group. I wonder that putting normal users in a user group may have something to do with solving this problem?

    Thank you for taking time to reply this thread.
    As you say, I mean the post in my thread, not the thread itself, or in others thread.
    I think this problem only happens when users with no forum privilege permission, like "administrator user group of forum" or "administrator user group of category". I suggest creating a normal user account for reproducing this problem when debugging. And I think the normal users may miss the permission to mark the post others write in the thread he/her create.



  • Any update on this?



  • Hi mp5gosu, thanks for following up.

    With regard to the issue, we need to upgrade the platform to 1.10.x or 1.11.x in order to get the issue solved.
    At the moment we're discussing the timeline and I'll promptly bump back here as soon as we've a final date.

    Apologizing for any inconvenience the issue is still causing, thanks for your patience.

    Best, Riccardo



  • Hi guys,

    I'm finally glad to state that by upgrading the platform to a more recent version you should be able not only to mark a topic as Solved but also to select the correct post solving the thread.

    Please verify on your side with your next-to-come threads and in case report any unexpected behavior.

    Best, Riccardo


Log in to reply