Compiling for R20


I'm trying to recompile my C4D plugin for R20 (Windows), and I'm having some issues.

Previously, I would first compile a static library for cinema.framework, and then add it
to my plugin project solution. But now, I can't even compile cinema.framework.

I understand things have changed, and I've read this:

And downloaded the Project Tool:

I ran it on this directory:

I was assuming the project tool would create a solution file (.sln) for me, which I could
loade into VS 2015, and then compile a static library, but it only creates a .vcxproj file.

Trying to load this .vcxproj into VS 2015 only gives me errors, and nothing gets loaded. So, I'm a bit confused and don't know where to go from here. Thanks.

Windows 7, 64-bit
Visual Studio 2015 Community

I solved my problem here:

I didn't realize I had to run the Project Tool on the entire SDK directory.

Maybe that thread should be a sticky at the top of the forums, because it makes more sense than the docs.


glad you were able to solve your problem. We'll take this as a hint and see if we can improve our documentation in this regard.