Solved How to use c4dpy for Cinema4D R20 SP1

Worked like a charm. Thank you.

The only possible clarification I would add (because despite your fantastic directions, this still got me for a few mins) is that you need to take the contents OUT of the unzipped folder, so that the c4dpy.exe sits in the same folder as the actual cinema4d.exe.

I'm aware you did explain this.. its just been a slow morning.


@alfieb Thanks for the heads up. Added a screenshot to clarify.

Thanks Donovan for your elaborate description.
I'll notify in this thread as soon as the section about c4dpy got added to the Python SDK docs.

One reminder:
Please help us to keep this place tidy and make use of the available tags, when posting. For this thread I already added some.

Hello everyone,
Someone have tested this workflow on mac? I'm trying to do it on a mac but i can't setup the IDE. Probably the problem is my lack in terminal shell usage but i don't know if possible to execute a .exe file via shell on a mac system. When i drag the file into the shell and after pressed enter i don't see this "Welcome to the world of C4D and Python 2.7.14 (default, May 3 2018, 18:05:57) [MSC v.1500 64 bit (AMD64)] (c) 2018" but this " -bash: /Applications/MAXON/Cinema 4D R20/ is a directory". If i drag the c4dpy.exe the result is: -bash: /Applications/MAXON/Cinema 4D R20/c4dpy.exe: cannot execute binary file
Going on i can't set up the environment properly. Someone could help me please? thanks in advance


Hi Giuseppe,
After the instruction from dskeithbuck, i set up on both windows and mac. With mac its a little different due the way the os packages things. You are getting the error message because the .app is indeed a directory. Open it by right click -> Show package contents -> Contents -> MacOS and in there is the executable you need.

Hope this helps.


@alfieb Thank you so much for your kindly reply! I have solved thanks to your suggestion :-)!


we have updated the Python SDK documentation including c4dpy instructions.
Let us know, if you are missing something in there.


I haven't been able to get c4dpy.exe to run without throwing an 0xC5 access violation error. I have the latest .exe downloaded and placed next to all the other C4D R20 executables, and my R20 instance is running R20.028. Does c4dpy.exe need to be updated for R20.028? I see lots of "UNKNOWNBUILDID" messages in stdout.


I'm terribly sorry for the inconvenience caused. You are right c4dpy needs to be updated for the latest hotfix (Cinema 4D R20 SP1, 20.028). Unfortunately due to our travels I had failed to upload the file. Sorry!
The updated version is now available on our blog's download page.


Cool! Thanks very much. That's working for me now.

@a_block could you update the link to latest version of c4dpy here?

Checkout my python tutorials, plugins, scripts, xpresso presets and more

@mikeudin Thanks for making us aware. We'll change the link with the next docs update.