change plugin's .h file,can not update



  • On 27/08/2018 at 03:58, xxxxxxxx wrote:

    Hi,
    For example, I set SPONE = 1001 in the header file, SPTWO = 1002, then I successfully loaded and ran the plugin in cinema 4d, but I changed the settings of the header file, such as SPONE = 1002, SPTWO = 1001 Then I run the plugin again in cinema 4d. I typed c4d.SPONE in the console but it will return 1001, and I didn't update the changes I made, even if I completely removed the plugin when I was in the console. When I type c4d.SPONE, it will still return 1001. It seems to be stored. I don't understand it very well. I want to know exactly how to ensure that the cinema 4d will be updated when I change the value in the header file again. What should I do?

    Thanks!



  • On 27/08/2018 at 10:42, xxxxxxxx wrote:

    1. Add a prefix to your symbol names (as in FAXWANG_PLUGINNAME_SPONE)
    2. The problem you encounter is due to the symbolcache. Hit the search with the term and you will find a bunch of threads
    3. Because of the instability of the symbolcache, I always recommend keeping a copy of the symbol information in your Python code and NOT access them through the c4d module.

    You can obviously automate converting the header files into Python syntax, for example with c4ddev.



  • On 28/08/2018 at 04:41, xxxxxxxx wrote:

    Hi,

    we just wanted to quickly agree with Niklas, your issue will be related to the symbolcache.
    Here I explained it in detail: https://plugincafe.maxon.net/topic/10886/14333_python-c4d-animating&PID=57335#57335



  • On 28/08/2018 at 05:47, xxxxxxxx wrote:

    Thanks,NiklasR!
    yeah,problem is symbolcache😉



  • On 28/08/2018 at 05:50, xxxxxxxx wrote:

    Thanks,Andreas!


Log in to reply