Reality Check ( v7 to v8 )



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 07/03/2003 at 09:58, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   8.012 
    Platform:   Windows  ; Mac  ;  Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Ok, I have spent three days trying to make the v7 scene file including a plugin import into v8 maintaining keyframes. This is a very serious issue and I have made little progress. Mr. Sterner stated he had gotten v7 files to import into v8. I am not sure if that includes parameter animation but that is what I really need to work. I can get parameter 'states' to read in and be set but that requires parameter IDs to be the same. I will maintain parameter ids if I absolutely have to but that is a waste of memory. I would prefer to have a function where I can read the keyframes with all data ( handles bias etc... ) and move it and change the sequence / parameter link. That would make this all work seemlessly. That is what I expect.

    As for the test I did, I set the plugin ID of the rounded tube in the v8 SDK to the same id it is in the v7 SDK ( why are these different? ). The parameter states read in but not the animation. The SDK examples not working is a very serious concern I do not consider this emulation. This is importing the data from a previous version. It is not an option.

    Please help!

    Thank you.

    bt



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 07/03/2003 at 10:37, xxxxxxxx wrote:

    Sorry, now I see what the problem is. In MSA I don't have any parameter animations, just an animation track. All plugin objects seem to have problems with imported animation, even "built-in" plugins like PolyReduction. I'll ask if there's a workaround. (Unfortunately emulation doesn't help you, since emulated R7 plugins also seem to lose their parameter tracks.)



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 07/03/2003 at 11:47, xxxxxxxx wrote:

    Thanks for your response. I have tracked down the parameter track through the document loading message. It seems to be deleted before the loading is finished ( assuming it is all there to begin with ). By allocating the seperate tracks and duplicating the sequences and keyframes I should be able to maintain the animation but this is going to get crazy.

    Let's Get Ready To Rumble!!!   ;-)

    bt



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 07/03/2003 at 12:24, xxxxxxxx wrote:

    Well, the track it found was the position track. Will this serious issue be resolved in v8.1? Being able to import v7 scenes with objects ( including parameter animation ) into v8 is not an option. This missing functionality impairs C4D's production viability. I state this is bold terms now as your other users will eventually figure out they are screwed when they need to use v7 ( v6!? ) projects. This is simply frustrating.

    bt



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 07/03/2003 at 13:20, xxxxxxxx wrote:

    Well now, after more evaluation I have found the following.

    All parameters from the parameter track ( once for every keyframe ) are passed to GetDParameter. Unfortunately there seems to be no data within the GeData set in 't_data'. Also, the 't_data' contains no parameter type.

    I really know if MAXON is going to resolve this problem in v8.1 or if I should go ahead and write a v8 import resolver. This resolution would find each plugin object, Search for a parameter track in the v7 scene and using a legend ( could be automatic if the parameter ids do not change ) update the v8 scene with the correct tracks/sequences/keyframes. This is important. Please inform me of the status.

    Thank You

    bt



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 08/03/2003 at 13:03, xxxxxxxx wrote:

    I'll keep you updated.


Log in to reply