strange issue, plugin not loading



  • On 30/05/2018 at 05:23, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:    
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    hello, i am facing a strange issue that my plugin isn't loading for one customer. no errors in the console. the very same plugin works for me in a fresh r19 demo installation. but when he puts the folder into his plugins, nothing happens.

    any ideas what could cause such behaviour?



  • On 30/05/2018 at 13:08, xxxxxxxx wrote:

    Could be a lot of things of course, but have you ruled out a plugin ID collision? Did you remember to acquire a unique ID from plugincafé?

    Perhaps you can ask the user to temporarily remove all other plugins and just run yours, to see if that works.

    /Filip



  • On 31/05/2018 at 02:32, xxxxxxxx wrote:

    Good morning ello, thanks for writing us.

    Beside the consideration from Filip, let me provide with a short checklist to better understand the cause:
    - are you providing Release binary aren't you? Consider that by default VS compiles the plugin in Debug mode and being debug libs not deployed on customers' environments the plugin simply doesn't load.

    - are you dinamically linking your plugin to other libraries which could lack on your customer's environment? (in this case i warmly suggest to ready this article and check your plugin with dependency walker)

    Looking forward further details, give best.
    Riccardo



  • On 05/06/2018 at 06:33, xxxxxxxx wrote:

    Thank you both for the feedback and sorry for comming back so late, but the notification doesn't work for me.
     
    Yes, I have a unique ID for the plugin and already asked the user to remove everything, which he tried with no success. he even set up a new demo installation which didn't work for him either.

    but, what could be the case is that i compile in debug mode. I'll check that. however, i never changed things so, it is strange that it worked before. And i checked it on another computer with the demo as well, so it shouldn't work there, too, right? but it did. very strange...



  • On 05/06/2018 at 16:46, xxxxxxxx wrote:

    You should definitely change to compile in Release mode. The reason it may have worked on your other machines could be that they also have the MS debug dlls installed. Perhaps all your test machines have visual studio installed? But your client will not have Visual Studio, so they won't have the debug dlls.

    I would compile in Release mode and then see if that works for your client.


Log in to reply