Issue with Cinema 4D Version



  • On 05/05/2018 at 01:40, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R19 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    I have created a plugin using the R19 framework, it is working fine with R19. I have tried to run this plugin with R18 but I found that it is not working. So what can I do to make my plugin generic that work with all version of cinema4D or I need to create the plugin for each version? Please do the needful.



  • On 05/05/2018 at 08:42, xxxxxxxx wrote:

    The simplest solution to this is to build the plugin in the earliest version of C4D you intend to support, then try it in later versions. In your case if you build it using the R18 SDK there's a very good chance it will run in R18 and R19. The other way round, it probably won't, as you discovered.

    Once you do this you will know which versions of C4D you will have to build your plugin for.

    Steve



  • On 07/05/2018 at 02:22, xxxxxxxx wrote:

    So It means every time for the new version I have to build the plugin to use the same sdk.



  • On 07/05/2018 at 05:23, xxxxxxxx wrote:

    Hi,

    it's just like Steve said, plugins are usually upwards compatible (plugin will work with later versions of Cinema 4D) but never downward compatible (won't work with previous versions of C4D).
    This was the case for many years (plugins developed for R13 still had good chances running in R19), so much, many people seem to take this for granted.
    Unfortunately we have to break this rule with R20. Please see our blogpost Plugin Compatibility for Cinema 4D R20


Log in to reply