Python not working (Which Version?)



  • On 08/02/2018 at 04:08, xxxxxxxx wrote:

    Hello, 
    I have installed C4D R19 on a Machiene with Windows Server 2012. It does not have python preinstalled.
    So I installed the latest Python from Python.org (v3.6.4) But C4D Python did not work.
    Than I tried Python 2.7.9. This times it worked in C4D. But certain Librarys seem not to work. eg. Teamrender Server WebInterface does not work. Also a Python Script that uses urllib2 does not work.
    On My other Machienes with OSX or Windows 10 these Scripts work.
    So now my question is which Python i need to install on my Windows Server Machiene? Or what could be the problem?

    Greetings, Holger



  • On 09/02/2018 at 01:56, xxxxxxxx wrote:

    Hi Holgar,

    Cinema 4D R19 comes with a Python 2.7.9 distribution so you shouldn't care about installing it. Python in Cinema is located in  $CINEMAFOLDER$/resource/modules/python.
    And Python comes urllib2 as it's included in its standard library.

    In the end, it looks like the installation you did is corrupt.



  • On 09/02/2018 at 02:23, xxxxxxxx wrote:

    Hey Yannick. I got it working now. The Problem was that I did not use the Installer of c4d.
    I needed to install a Mircrosoft Redistributable manually.
    Thank you anyway.



  • On 09/02/2018 at 02:32, xxxxxxxx wrote:

    Makes sense.

    You're welcome.


Log in to reply