Modeling Kernel Error constantly crashes C4D



  • On 19/01/2018 at 19:54, xxxxxxxx wrote:

    Modeling Kernel Error constantly crashes C4D when I'm using MCOMMAND_MELT In object modifier plugin.
    It generates tons of Error messages when I'm tweaking settings and then completely crashes C4D.

    It works if I'm dropping object to modify under generator(e.g. Connect) and modifier after it.
    I also tested it with Object Generator plugin and C4D's Python Generator and it works like a charm.

    class Otopoformer(plugins.ObjectData) :
      
        def Init(self, node) :
            self.InitAttr(node, float,[c4d.DELTA])
            node[c4d.DELTA] = 0.5
            return True
      
        def ModifyObject(self, mod, doc, op, op_mg, mod_mg, lod, flags, thread) :
      
            sel = op.GetEdgeS()
            sel.Select(1)
            res = c4d.utils.SendModelingCommand(command  = c4d.MCOMMAND_MELT,
                                                list     = [op],
                                                mode     = 3,
                                                doc      = op.GetDocument(),
                                                flags    = 1) 
            return True
    

    I think it will work if I'll send op into virtual Doc, perform modifications there and bring it back to the base document, but I never tried this with modifier plugins and I don't know a correct way of doing this.



  • On 19/01/2018 at 21:30, xxxxxxxx wrote:

    Well... I executed another modeling operation after MCOMMAND_MELT and it solved the problem.



  • On 22/01/2018 at 05:43, xxxxxxxx wrote:

    Hi Merk, thanks for writing us.

    With regard to your support request I'd say that both the problem you've encountered and the solution you've found are hidden to me considering your first and second posts. Could you consider to better circumstantiate what was not actually working as expected and how you were able to make it work?

    Looking forward your comment, feel free to get back for any further support.

    Best, Riccardo


Log in to reply