plugin subfolder weirdness



  • On 09/11/2017 at 02:08, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R19 
    Platform:      
    Language(s) :     C++  ;

    ---------
    I have this feedback from a user of my Seamilar plugin that he re-arranges his plugins into subfolders. All UV related ones are in a subfolder UV, all architectural into Architect ... and so on.

    The strange thing is that when only one plugin is moved to a subfolder all remains unchanged.
    When the subfolder contains 2 plugins or more, then the structure in the plugin menu changes, and for some reason (unknown to me) my tag plugin doesn't show up in the list anymore.

    a short demonstration of the process of moving plugins to subfolder:
    http://youtu.be/hchQMXnFYdc

    According to the user this worked in R18 and before, not in R19 anymore.

    I register the tag with following code

      
      RegisterTagPlugin(SEAMILAR_TAG_PLUGIN_ID, GeLoadString(IDS_SEAMILARTAG), TAG_VISIBLE, SeamilarTag::Alloc, "Tseamilar", AutoBitmap("Seamilar.tif"), 0);  
    

    Daniel



  • On 09/11/2017 at 02:23, xxxxxxxx wrote:

    Did some further investigation, and I now noticed that the tag menu in the Object Manager hs now an entry with the name of the subfolder, and my tag and its parent group is found in there.

    Guess we can skip this whole topic and set this to solved.
    Sorry.



  • On 10/11/2017 at 02:29, xxxxxxxx wrote:

    Hi,

    yes, that's roughly the intended behavior.
    We are not aware of any changes in this behavior between R18 and R19.



  • On 14/11/2017 at 04:35, xxxxxxxx wrote:

    Only saw today the topic got a reply. Sorry.

    Thanks for the confirmation Andreas.


Log in to reply