Failing to build Melange examples [SOLVED]



  • On 22/06/2017 at 01:54, xxxxxxxx wrote:

    Hello,

    I am trying to understand Melange C++ library so I thought a good start was to build the examples given in the Melange download folder. I opened "examples.xcodeproj" with Xcode 8.2.1 (I also tried with Xcode 7.0 but same problem) and I built the "examples" project with "All targets". The building fails with error message :

    'operator=' is a private member of 'melange::BaseArray<melange::OverrideMapEntry, 16, melange::::BASEARRAYFLAGS_0, melange::DefaultAllocator>'

    (at line 78 in c4d_baseoverridedata.h and same error message at line 195)

    In fact, when I am trying to build "renderconnection.xcodeproj" with RenderConnection, the building fails with the same error message.

    Am I doing anything wrong ? I am on MacOS Sierra 10.12.3

    Thanks,

    Lina



  • On 23/06/2017 at 05:34, xxxxxxxx wrote:

    Hi Lina, thanks for writing us and, first and foremost, welcome to our Plugin Café forum.

    I confirm that the "examples" project (which contains the commandline  and the renderconnection project) can't currently compile due to an issue in the renderconnection project configuration files preventing the renderconnection example to be properly compiled on MacOS (with both Xcode 7 and 8).

    At the same time I warmly suggest to start looking at the commandline example, which, on the contrary, compiles flawlessly. By far the commandline example represents the baseline to start moving the first steps in Melange and looking around the code used there could be indeed interesting.

    I'll keep you updated when the issue with the renderconnection project will be fixed.

    Best, Riccardo



  • On 26/06/2017 at 01:48, xxxxxxxx wrote:

    Hi Riccardo, Thank you very much for your quick answer.

    I still have a problem : I built the commandline project on Xcode, but here is what I get in the terminal :
    **
    **
    __________________________________


    **    Melange 18.008 Commandline Tool**
    **  ___________________________________**


    **  # Dokument #**
    **  - File: "/test.c4d"**
    **    file is not existing**
    **    aborting...**
    **  <press return to exit>

    **So I created a "test.c4d" file and put it in beside "C4DImportExport.cpp" in the source folder but it is not working. Where shall I put that file ? Or shall I do something else ?

    Thank you again for your help,

    Lina

    < ="text/"> p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #000000} p.p2 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #000000; min-height: 13.0px} span.s1 {font-variant-ligatures: no-common-ligatures}



  • On 08/08/2017 at 01:36, xxxxxxxx wrote:

    Hi,

    I was just using wrong paths. My problem is solved !

    Thank you very much for your help,

    Lina



  • On 28/08/2017 at 00:27, xxxxxxxx wrote:

    Hi Lina, please consider that a new Melange SDK has been released fixing also the issue you faced.

    Best, Riccardo


Log in to reply