Plugin alwas has shader GUI no matter what I do



  • On 17/06/2017 at 09:10, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   18 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    I am trying to write a simple object plugin. My problem is that the object of my plugin it always has the shader GUI. I have very carefully put an *.res and *.h file into \res\description. But it does not matter what I write into it. Actually if I delete the file altogether, I still get the same shader GUI. I also have checked multiple times that the string of RegisterObjectPlugin's "description" parameter matches the filename.

    In the console of C4D I get an error that says "Description Error: OMyPluginTest is already registered". This does not make any sense to me, since there is no other plugin with that name. Also the message corresponds to what I write into the "description" parameter, and it seems I can put essentially any random name there and I still get the same message.

    I am completely clueless where the error as well as the shader GUI comes from.
    Thanks for your help.



  • On 17/06/2017 at 10:53, xxxxxxxx wrote:

    Did you get a unique plugin ID from Maxon? Because if you used one of the 'test' IDs that you can use when prototyping a plugin, that will give you the error if another plug has used it too. It isn't the name that matters, it's the plugin ID which must be unique.

    Steve



  • On 17/06/2017 at 11:35, xxxxxxxx wrote:

    Yes I did, but apparently I used that one somewhere else? I don't know. Anyway, I changed it and it works now.

    Thank you for your help.



  • On 19/06/2017 at 00:32, xxxxxxxx wrote:

    Maybe you have two binaries in your plugin's folder? It happens to me sometimes that I do my first build before doing further adjustments to the project file, so I get something like "cinema4dsdk.dylib", and then later I change the product name in the project, build again, and also get "myplugin.dylib". Cinema tries to register plugins from both binaries, but - of course - fails with one of them.


Log in to reply